SciFinder Scholar – older versions no longer supported

Posted February 2nd, 2006 by mit-admin

As of March 31, 2006 older versions of SciFinder Scholar will no longer be supported. This includes any versions prior to version 2004.2 and version 2006.

To upgrade to the latest version of SciFinder Scholar, visit http://libraries.mit.edu/guides/cheatsheets/sci-finder/installation.html.
You must have MIT certificates to install SciFinder Scholar.

Questions? Contact Erja Kajosalo, kajosalo@mit.edu, Chemistry Librarian.

--