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Introduction to GIS for Architects 

Set up your Geodata Repository account 

You will need an MIT Geodata Repository Account before beginning the next exercise. If you do not 

already have an account, you can create one (libraries.mit.edu/gis/data/repository.html). Create a user 

account.  You will need the password for the next exercise. You will get a message stating that your 

account was successfully created upon completion. 

Table of contents 

1. Creating a basic map 

a. Add data to your map from a file 

b. Add data to your map from the MIT Geodata Repository 

c. Change the ordering of the layers drawing on your map 

d. Symbolizing a layer 

e. Select data based on specific attributes 

f. Labeling your data 

g. Scales and site bookmarks 

h. Export selected data to a new shapefile 

i. Export to AutoCAD format 

j. Layout your map for printing or saving for a presentation 

k. Save and export your ArcMap document to pdf or other formats 

l. Create a map package to easily pull all the files for your project together 

2. Exploring Demographics 

a. Symbolize using graduated colors 

b. Select by location 

c. Create a data graph 

3. Adding aerial imagery from arcgis online 

4. Map point locations: Add xy data 

5. Georeference an Image: Make an image line up with the other map data 

6. Edit a data layer and create a new feature 

7. Generating contour lines from terrain data 

8. Working in 3D with ArcGlobe 

a. Set the buildings to display in 3D 

b. Navigating in ArcGlobe 

9. Challenge exercise – create an animation fly-through between 3 buildings in ArcGlobe 

  

libraries.mit.edu/gis/data/repository.html


An Introduction to GIS for Architects 

2 

Creating a basic map 

ArcGIS is a set of multiple programs. In the following exercises you will use ArcMap to do mapping and 

analysis and ArcCatalog to manage GIS data. ArcCatalog also enables you to create new, empty datasets 

into which you can digitize new features. In this exercise you will make a quick map of roads, parcels, 

and buildings in Cambridge, MA. 

1. Copy the tutorial data folder called “usertemp” from the T:\GIS-arch folder to the WorkSpace 

folder of your C: drive, or from libraries.mit.edu/gis/teach/archintro.html. You will save data and 

maps in the WorkSpace folder for these exercises. If you have a USB drive, you can copy this 

folder and take it with you when you leave to work on later. 

2. Start ArcMap (Start menu > All Programs > ArcGIS > ArcMap), and start with an empty map. Click 

OK. 

You make a map by adding various kinds of data to ArcMap; the data gets displayed in the map as layers.  

You can turn individual layers on and off, re-arrange the order in which they are drawn, change the 

symbols for the layers, and add labels based on attributes of the layers. You can save the map document 

to preserve a particular arrangement of layers for a later session. 

Add data to your map from a file 

1. Click the Add Data button ( ) on the toolbar 

near the top of the ArcMap window. 

2. Click the Connect to Folder button ( ), and 

navigate to the C: drive. Select the C: drive and 

click OK. 

3. Navigate to the C:\WorkSpace folder on your 

machine, where you should see 

MajorRoads.shp (this is the same as Cambridge 

Major Roads in the Geodata Repository). 

This data is stored in a shapefile, so the icon is green, and it contains line features, so the icon has lines 

on it. Shapefiles are a very common file-based type of GIS data. ArcMap and ArcCatalog show you 

shapefiles as single objects, but they are in fact made up of several files in the file system. It is important 

to keep all files with the same name, and different extensions together, if moving your data. If you use 

ArcCatalog to move your files around, it will automatically keep all the appropriate files together. 

4. Select this MajorRoads.shp and click OK. 

In the ArcMap Table Of Contents, the layer name, MajorRoads, appears with a line symbol below it. The 

layer name is based on the shapefile name (you can change it). The major roads in Cambridge are also 

displayed on your map; they are all drawn as simple lines in one color. These lines represent the major 

roads as vector data—that is to say, as features made up of one or more XY coordinate pairs, with line 

segments connecting each coordinate to the next in the feature.   

http://libraries.mit.edu/gis/teach/archintro.html
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MIT Geodata Repository Search Toolbar for ArcMap 

Now you’ll add another layer to ArcMap, using the MIT Geodata Repository Search Toolbar. This is a cool 

custom tool that lets you search for data for your maps from the 1,400+ layers stored in the MIT 

Geodata Repository, an international collection of GIS data. You may need to add the MIT Geodata 

Repository toolbar to ArcMap, if it’s not already displayed.  

1. To add a toolbar, right-click in the gray area above the ArcMap data frame (the window showing 

your major roads line features), and you’ll see a long context menu list of toolbars. Find the MIT 

Geodata Repository tool in the list and click it. 

2. Click Search Metadata on the MIT Geodata 

toolbar, and login with your Kerberos ID and 

Geodata Repository password. 

3. A box appears where you can type search 

parameters. In the “Search For” box, type 

Cambridge Parcels as a title, and click Search. 

4. Several layers of parcel data from Cambridge appear in the list; we’ll use the latest one. Click 

Cambridge, MA (Parcels, 2008), and click Add Selected Layer to Map. Click Exit to quit the tool. 

The parcels are stored in a database, the MIT Geodata Repository, along with a lot of other feature 

classes and raster datasets. Feature class is just another way of saying a vector layer, like the major road 

shapes you added. When you add the parcels layer, the name is long and messy; it contains information 

about the database where the data is stored, and a coded name for the data. You can change the name 

displayed. 

5. Click twice (but slowly) the new layer name in the ArcMap table of contents to get a cursor to 

change the layer name. Change the name to Parcels. You can also do this in the Layer Properties 

dialog box. 

Searching for data and adding it to your map using MIT Geoweb 

Now you’ll add another layer to ArcMap, using MIT GeoWeb. GeoWeb lets you search, view, and access 

data from the MIT Geodata Repository using a web browser. This is handy when you’re using a machine 

that doesn’t have ArcGIS installed, and you want to find some data to use later. 

1. Open a web browser (the one you used to get your MIT personal certificate on this computer) 

and go to web.mit.edu/geoweb/. Click the Enter GeoWeb button to enter the site. Anyone can 

search MIT GeoWeb, but you need an MIT personal certificate in order to view or download 

data that is restricted by license agreements. 

2. In the Search box, change to Title, type Cambridge buildings, and click the Search Metadata 

button. 

3. You’ll use the Cambridge, MA (Buildings, 2006) layer. Click the info (i) button to see a description 

of this data. 
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Metadata describes things like what the data is, who made it, use constraints from license agreements, 

and who to contact if you have questions about it. Most datasets have metadata, and you can usually 

view the metadata in ArcCatalog. You can also use ArcCatalog to edit the metadata for your own data, 

for example to make notes about what processing steps you used to create it. Have a look at the 

metadata for the buildings. What attribute of the building features table contains the elevation of the 

highest point on the building? 

1. Close the metadata window, and click the draw button 

(arrow icon) beside the buildings layer. Click the Save 

link to MIT Layers button. A message box titled Custom 

URL appears.  

2. Right-click and copy the link (Copy Link Location or 

Copy Shortcut). You could copy this into an e-mail or 

note to yourself to have a quick way to get back to this 

layer. You can also use the link to add data directly to ArcMap now, since you have it running. 

3. In ArcMap, on the MIT Geodata Repository toolbar click Data from Geoweb, paste the URL, and 

click Add Layers. The new layer of building footprints is added to ArcMap. 

 

4. Change the name of the new layer to Buildings, and close the MIT GeoWeb browser window. 

Change the ordering of the layers drawing on your map 

1. You can re-arrange the order of layers in the ArcMap table of contents. Click the Buildings layer 

in the table of contents and drag it below the parcels layer. The lowest layer in the table of 

contents is drawn first, and the highest layer is drawn last.  

2. The parcels should cover the buildings; un-check the box beside the parcels layer to turn the 

parcels off. You should be able to see the buildings again. When you’re making maps it is handy 

to know that you can re-order the layers and turn layers on and off. 

3. Turn the parcels back on. 

4. Re-arrange table of contents so that the drawing order (from bottom to top) is Parcels, 

Buildings, then Major Roads, so you can see all of the features. 

Symbolizing a layer 

1. Right-click the patch of color below the Parcels layer in the table of contents. You should see a 

swatch of different colors. Click a new color to represent the parcel features. 

Like the roads, all of the parcels are being drawn with the same symbol. In the case of the roads, it is a 

simple line symbol with one color for all roads, and in the case of the parcels it is a simple fill symbol of 
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whatever color you picked. Now you’ll change the symbol for the roads so that you can differentiate 

between two different types of road. 

2. Right-click the Major Roads layer; you should see a long context menu. Click Properties. A new 

dialog box opens that lets you inspect and control a lot of different properties of the layer. The 

dialog box is organized by a series of tabs across the top. 

3. Click the Symbology tab. On the left side of the dialog box, it currently says Features: Single 

symbol to indicate that all of the roads are being drawn with the same symbol. Below this in the 

list are other ways to symbolize the layer.  

4. Click Categories, and click Unique Values. 

5. The data field that you’ll use to differentiate the types of road is called MAJORROAD. Click the 

Value Field drop-down list and click MAJORROAD to select this as the unique value field. 

6. Click Add All Values. 

Now there are two symbols that represent features with data values 

of 1 and 2; these are codes for different road types.  A different road 

shapefile might use a different set of codes (perhaps textual ones like 

“highway” and “dirt two track” to identify different types of road, or 

it might not have a road type attribute at all. You can often find 

explanations for the codes used to represent data attributes in the 

metadata for a GIS dataset (though not always). 

7. Double-click the line symbol next to type 1 roads. A dialog box opens where you can set the 

symbol for the type 1 road features. 

Note that there are a lot of pre-defined symbols, some of them quite complex. You can change the 

symbol to one of those by clicking the symbol in the left side panel of this dialog box. You can also 

modify the existing line symbol’s color and size using the color swatch shown on the right side of the 

dialog box; this lets you pick a new color the way you did earlier for the parcels. 

8. Change the color of these roads to black, and make the line width 3 points. Click OK and you’ll 

return to the Symbology tab of the Major Roads layer properties. 

9. Double-click the line symbol for type 2 roads, and use the same method to change the symbol 

for these roads to a dark gray with a medium line width (2). Click OK to close the Major Roads 

layer properties dialog box. Now you can see the map with the new road symbology. 

Select data based on specific attributes 

1. Now we’ll use another attribute of the 

roads, the road name, to find a particular 

location.  Click the Selection menu (at the 

top of the ArcMap window) and click Select 

by Attributes.  
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2. In the Select by Attributes dialog box, the first task is to specify from which layer you want to 

select features. Click MajorRoads in the Layer dropdown list. This starts building a SQL query 

which is displayed above the lower of the two white areas on this dialog, “SELECT * FROM 

MajorRoads WHERE:”. A list of the attributes of the layer appears in the upper of the two white 

areas. 

3. Double-click “ST_Name”. This attribute is added to the 

lower white area. 

4. Click the = button. An equals sign is added to the query 

expression. 

5. Click the Get Unique Values button, and double click 

‘Brookline’ in the values list. Click OK. 

The dialog box goes away and Brookline is selected and drawn with 

a cyan line (in ArcGIS selected things are usually highlighted with 

cyan or drawn in cyan; you can change this if you want to, in the 

Selection Options, but cyan is fine for now). 

6. Click the Zoom In tool button ( ) and click and drag a box 

around the lower end of the selected street segment. The 

map will zoom to this area.   

Scales and site bookmarks 

In the Scale box (beside the Add data button) the current map scale is displayed. The current map scale 

will depend on your screen size, your ArcMap window size, and the size box you just dragged. 

1. Double-click in the scale box and type 5000 and press the Enter key. The map zooms in or out a 

bit so the scale is 1:5,000. 

2. Click Bookmarks, and click Create. 

3. Name the new bookmark something like “project area”. Bookmarking an area makes it easy to 

get back to, in case you to go looking at another part of your data. 

Labeling your data 

1. Now you’ll label the roads. You’ll use the Labeling toolbar, but you’ll probably need to add that 

toolbar first (right-click in the gray area above the ArcMap data frame, find the Labeling toolbar 

in the list and click it). 

2. On the Labeling toolbar, click the Label Manager button ( ).  

3. In the Label manager dialog box, check 

the box beside MajorRoads. Click 

Default (the name of the label class). 

Set the Label Field to ST_NAME. You 

can change the font and size of your 

road labels here too. Increase the font size to 12 to make the labels easier to read. Click OK. 
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Zoom in and out of the map and watch the labels (you can use the Fixed Zoom In and Fixed Zoom Out 

tools, which have four arrows pointing in and out, respectively, from the center of the button). The 

labels stay a constant size on the screen because they’re set to display at 12 point. If you zoom out to 

the whole extent of the data (the globe button), you can still see them. When you are making a map 

that you plan to print at a particular scale, you can set a Reference Scale for the data frame. With a 

reference scale set in the map, the labels and symbols will be fixed so they appear at the specified point 

size when the map is zoomed to the reference scale; they 

appear smaller when the map is zoomed out, and larger 

when the map is zoomed in. Now you’ll set a reference scale 

for a map. 

4. Right-click Layers (that’s the name of the dataframe) 

in the ArcMap Table Of Contents, and click 

Properties.  

5. Click the General tab. In the Reference Scale box type 

5000, and click OK.  Try zooming in and out again and 

watch how the labels (and symbols, especially the 

Major Roads symbols) behave.  

6. Click Bookmarks and click project area to return to 

the project area. 

Now you’ll use the Select by Attributes tool to select a particular parcel, parcel 65-55, from the parcels 

layer. 

7. Click the Selection menu 

8. Click Select by Attributes. 

9. Make the selection from the Parcels layer, and select on the ML field. The expression in the 

white box below the Where clause should be:  ML = ’65-55’. This will select the parcel feature 

with a ML code value of 65-55. 

10. Close the Select by Attributes dialog box after you’ve selected the parcel. The cyan highlighted 

parcel should be between Brookline, Putnam, Vasser, and Memorial. 

Export selected data to a new shapefile 

Now you’ll export this single selected parcel feature into a new shapefile of its own. Exporting selected 

data is a very handy way to extract a subset of the features that you need from an unmanageably large 

original dataset. It is especially important to slim your 

files to only the data you need when exporting to 

CAD or working in 3D. 

1. In the Table Of Contents, right-click the 

Parcels layer, point to Data, and click Export 

Data.  
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In the Export Data dialog box the words Selected Features will be highlighted in the Export drop-down 

list (if there were no selected features, it would say All Features; you could export all the features now, 

but that would be counterproductive). To the right of the Output shapefile or feature class: text box is a 

folder button. 

2. Click the folder button to navigate to a new location where the shapefile will be stored. Navigate 

to the WorkSpace folder, and click the New Folder button ( ). Type your MIT username as the 

new name of the folder. 

3. Double-click your new folder, and name your file Myparcel.shp. Click Save.   

4. On the Export Data dialog box click OK.  Click Yes to add the exported data to the map as a new 

layer.   

5. Change the symbol of the Myparcel layer to a 

new color that contrasts with the other 

parcels (right-click the symbol patch below 

the layer name to get the color picker, then 

click a color). 

6. Click Selection in the top menu of tools, and 

click Clear Selected Features to get rid of the 

cyan highlight around the parcel in the 

Parcels layer. 

Export to AutoCAD format 

1. The tools for exporting to CAD formats are in ArcToolbox ( ). Inside ArcToolbox, navigate to 

Conversion Tools > To CAD > Export to CAD. 

2. Select Myparcel as the input feature. The Output Type provides several DWG and DXF format 

options. Select your preferred type, the location for the Output File, and click OK.  

Layout your map for printing or saving for a presentation 

1. You’ll make a map layout that you could print. Click the View menu and click Layout View. 

Now you can see a page layout. You can arrange the data frame and other things commonly found on 

maps (a title, scale bar, legend, North arrow, graphics) on this page. The page is a letter size sheet, with 

a portrait orientation, but you can change the page size to much larger sizes depending on the printer 

you plan to use. For this exercise we’ll stick to the 

default page size, but we’ll change the orientation to 

landscape. 

2. Go to File > Page and Print setup. 

3. Click the button beside Landscape, and click 

OK. The page orientation is now landscape. 

The data frame may be hanging off the page a bit; 

that’s ok, you’ll fix it. 
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4. Click the Select Elements tool (it is a black arrow, on the same tool bar as the Zoom In tool) and 

click on the data frame (the map). When it is selected you can see little resizing handles on the 

edges and corners. Click the data frame again and drag it so that one edge is just inside the 

page, then click one of the resize handles and drag it to resize the data frame so there is room 

along one side of it and above or below it to add a scale bar, legend, title, and north arrow.  

5. Click Insert > Scale Car (notice Insert is only 

available when you are in the layout view, 

not when you are in the data view). Select a 

scale bar that you like and click OK. Click and 

drag the scale bar to a place on the page 

layout. Grab one of the resize handles and 

make it a nice size. If it looks cluttered, or 

you want to change the number of divisions, 

double-click the scale bar and reduce the 

number of divisions, then click OK).  

6. Use the same approach to add a North arrow 

to the map. Insert a title, and name your 

map something like My Project Area. 

7. Insert > Legend. The Legend wizard lets you choose which layers to show in the legend, how 

they’ll be represented, how the legend will be titled and framed, the spacing of the items, etc. In 

this case you can just click Next a few times to finish and add a default legend to the map. 

8. Arrange all these elements to make a map composition that suits you. You may need to resize 

some of them. If you change the map scale, the scale bar will automatically update.  

 

When you switched to Layout view the Layout toolbar was added to the ArcMap window. This toolbar 

lets you Pan and Zoom on the page layout (as opposed to panning and zooming the data frame). If you 

move the pointer over a tool on any ArcGIS toolbar and leave it still for a 

few seconds a tool tip with the name of the tool will appear. Compare 

how the Zoom to Whole Page and Zoom to 100% tools work. 

9. In the course of this the map scale may change a bit; when you’ve 

got your layout the way you want it, click in the Scale box and 

type 5000, then press the Enter key. 

Save and export your ArcMap document 

1. Save your map (File > Save As). 

2. Navigate to your folder. Type a name for the map (MyFirstMap) and click Save.  
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This saves your map as an ArcMap document, which references the location of the data layers in the 

map and the way they are symbolized. If you want to work on this document on a different computer, 

you need to make sure to copy the referenced data, as well as the ArcMap document. There is no 

‘packaging’ option like some other software programs, but you can save a map in the same folder with 

its data, and set the map to use relative pathnames (File > Map Document Properties > Store relative 

pathnames to data sources). When you move the folder with the data and map, the map will maintain 

its links to the data. 

3. Rather than printing this map, you’ll export a PDF of the map. Click 

File > Export Map. Note that you can also export as a bunch of graphic 

types like TIF, BMP, and JPEG images, and vector formats like SVG, 

EMF, PDF, and Adobe Illustrator (.AI format). 

4. Navigate to your folder.   

There are a lot of settings that you can use to optimize PDF export. At the 

upper right corner of this window there is a button with a question mark on 

it. You can click this button and then click the various controls to get some 

more information about the options. The ArcGIS Desktop and Web Help also have topics about the ins 

and outs of exporting to PDF. 

5. From the Save as type dropdown list 

choose to export as a PDF. In Options 

> General tab set the resolution to 

300 dpi. In the Format tab and click 

the box to Embed All Document 

Fonts (the north arrow and some 

map symbols are based on fonts 

If you don’t export using embedded fonts 

then when you look at your exported PDF on 

a different machine you may not see these 

parts of your map, or you may see odd 

characters instead of the symbols that you 

were expecting). The Adobe Illustrator format 

export does not support font embedding, so 

you can see the same sort of problem in 

maps exported to AI format. One work-

around might be to export to PDF, then place 

the PDF in Illustrator and flatten the image, 

converting all text to outlines. Another might 

be to make sure that all of the fonts you use in your map are installed on the machine where you use 

Illustrator. 
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6. Click Save to save the PDF file.   

By default ArcMap exports PDFs with different layers that can be turned on and off from within Adobe 

Reader; you can also tell it to export some of the attribute data for the features, though this makes for 

large PDF file sizes. 

Create a map package to easily pull all the files for your project together 

1. Go to File > Create Map Package 

2. ArcGIS will prompt you to first write a (brief) description of your map in the Description field. 

3. Choose Save package to file, and navigate to your folder. Validate the package, then click share. 

Creating a map package is a new method of keeping both your map document (the shell) and your 

individual layers and tables in one file so that you can move it from computer to computer without 

having to worry about leaving anything behind. 

Exploring Demographics 

Now we’ll explore the demographics of this area. 

Symbolize using graduated colors 

1. Revert to your data view (View > Data View), and click the Add Data button. 

2. From the folder where your data is being stored, add the Middlesex_income1999 shapefile. 

You have now added a shapefile of census tracts in Middlesex County, MA (where Cambridge is located) 

with data describing the median household income in the attribute table. 

3. Right click the new layer and click Properties > Symbology > Quantities > Graduated Colors. 

4. In the Value drop-down list choose 

MEDHINC (the income field). In the 

Classification Classes: drop down list 

choose 10.  You can also pick your own 

color scheme in the Color Ramp drop-

down menu. 

5. Click OK.  Zoom to the whole extent of the layer (right click on 

the layer and click Zoom to layer).  

6. Let’s look at a tabular view of the data. Open the attribute 

table for CensusInc (right-click CensusInc, click Open Attribute 

Table).  

7. Scroll to the far right of the table (you’ll see the column 

MEDHINC), right click the header block of the column, and 

click Statistics. You can see a histogram of the distribution of 

aggregate income by census tract, as well as 

Count, Min, Max, Sum, Mean, and Standard 

Deviation values. 
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8. Click in the statistics report box, click and drag to select all the contents, right-click, and click 

Copy.   

9. Open Notepad (Start menu > All Programs > Accessories > Notepad), and paste the data into an 

empty text document. Close the Statistics window. 

We’ll see how much money was made in the area near MyParcel, in Middlesex county (note: to do an 

accurate analysis you would need to also include the Census 

tracts across the river in Suffolk county, but we’ll skip that 

for this exercise). 

Select by location 

1. Click the Selection menu and click Select by Location.  

Selecting by location is a database query like the select by 

attributes query you did to find the street, but instead of 

searching in the attribute fields for data that matches some 

query string, the GIS searches geographically. 

2. In the Selection method drop-down list at the top, 

click Select features from (there are other selection 

types available, but this is the default) and check the 

box next to middlesex_income1999. 

3. In the Source layer box, click My Parcel, and for 

Spatial selection method, click “Target layer(s) 

features intersect the Source layer feature. 

4. Check the box to apply a search distance to the features in MyParcels. Type 5 and click a 

distance value of Miles. This will select census tracts within a distance of 5 miles of the MyParcel 

layer (it only contains a single feature; if there 

were many you could select one of them before 

hand, or select features that were within 5 miles of 

any of them). Click OK. The nearby census tracts 

are selected.   

5. Open the attribute table for your layer again if you 

closed the table (right click the layer name, and 

click Open Attribute Table). 

6. Scroll to the column the furthest right in the 

table, MEDHINC, right click the header block of 

the column, and click Statistics. Now you get 

the statistics for the selected features. 

7. Right-click the middlesex_income1999 layer in 

the Table of Contents > Data > Export Data.   
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8. Export the selected features to a new shapefile called CensusIncLoc.shp in your usertemp folder, 

and add it to the map. 

Create a data graph 

Now we’ll make a graph of the data and explore it along with the 

geography.  

1. Click View, point to Graphs, and click Create.  

2. Choose histogram, the CensusIncLoc layer, and MEDHINC as 

the value field. Accept the other defaults, Next, and Finish. 

The graph opens in a new window. 

3. Arrange it beside the data frame so you can see both at the 

same time. Click the Select Features tool ( ), and select one 

of the census tracts on the map.   

Notice that both the feature and the corresponding column in the 

graph are highlighted in cyan. If you click columns in the graph, the corresponding features are selected 

on the map. If you right click on the graph, you can copy it as a graphic, export it to a number of 

different file formats, add it to the ArcMap layout, and modify various properties of how the graph is 

displayed 

4. Save the map.  

 

Adding aerial imagery from ArcGIS Online  

Turn off (uncheck) the CensusIncLoc and CensusInc layers, turn on My Parcel and CensusIncLoc, and 

zoom back to the project area by clicking Bookmarks > project area bookmark. 

Adding aerial imagery from ArcGIS Online 

You’ll add some background imagery to the map from 

the web.  

1. Click File > ArcGIS Online.   

2. Search Imagery. Select World Imagery, and click 

Add.  

The layer will download and then it will be added to 

ArcMap. It takes a little while, so be patient. If you see a Geographic Coordinate System warning, it’s not 

important in this case, so click Close. The layer (actually, 

a set of layers, called a Group Layer) will appear in the 

map and at the bottom of the ArcMap table of contents. 
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Map point locations: Add xy data 

Next, you’ll add a table that contains the coordinates of some control points to the map and display the 

coordinates as points. These will serve as control points to georeference an image. 

1. Click the Add Data button, navigate to the folder you’re using, and add the ControlPts.dbf table.   

The table of contents will switch to Source tab view (you can see the tabs at the top of the table of 

contents) so you can see the table. 

2. Right-click the ControlPts table in the table of contents and click Open.   

This is a very simple table with four records. Each one contains coordinate information, such as a 

surveyor might collect (you might go out and collect control points with a GPS, depending upon the level 

of accuracy your project requires). Close the table window. 

3. Right-click the ControlPts table, and click Display XY data. 

4. Choose the Point_X field for the X Field, and choose the 

Point_Y field for the Y Field. 

These control points are in the same coordinate system as the 

MajorRoads layer that you added to ArcMap at the beginning of 

Exercise 1, so they line up with the other data well. If they had been collected with a GPS unit and 

contained latitude and longitude data, you would have needed to specify the coordinate system that 

they were collected in (for GPS data that is usually Geographic coordinates and the WGS84 datum). You 

should set the coordinate system. Since we know the coordinate system matches the MajorRoads layer, 

we can import the coordinate system.  

1. Click Edit > Import > MajorRoads > Add > OK > OK. 

2. Rename the layer Control. The new points are displayed on the map. They match known 

locations on a plan you’ve got for the building footprint.  

Georeference an Image: Make an image line up with the other map data 

You’ll georeference an image file of the footprint to the control points. 

1. Add the Bldg_FP.bmp raster to ArcMap. 

2. The image does not have any geographic information associated with it to tell ArcMap where in 

the world it belongs, so you get an Unknown Spatial Reference message box. Click OK.   

Georeferencing an image (or a CAD drawing) is the process of specifying, in an interactive way, where it 

belongs relative to other known features on your map. You can save this information with the image so 

that whenever you add it to your maps, it appears in the right place. This is a handy way to add historic 

maps or old aerial photos (and CAD drawings) to your GIS. In this exercise the image includes the 

footprint of a hypothetical building. You’ll georeference the image to the control points so that later you 

can digitize the shape of the building footprint into your GIS. 
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3. Add the Georeferencing toolbar to ArcMap (right click in the grey toolbar area).  

4. On the Georeferencing toolbar, set the target layer to be Bldg_FP.bmp. Click Georeferencing 

and click Fit to Display.   

This roughly moves the image to the area you’re currently zoomed to. You may need to zoom to the 

extent of the Control layer (right click the Control layer and click Zoom to Layer) and then fit the image 

to the display again. Turn the layer off and on to look at where the control points fall relative to their 

marked position in the image.  

5. Click the Add Control Points tool, on the 

Georeferencing toolbar (a green plus sign and a 

red plus sign with a line connecting them). 

6. Click the lower left control point on the image 

(the control points in the image are shown as 

triangles with a dot in the center), and then click 

the corresponding Control feature (the control 

point features have a circular symbol).  

Your display will probably not look exactly like this image. Repeat this for the other control points. The 

image should move into place, getting a better fit with each control point you add. 

7. Click Georeferencing > Rectify. Save the new file in .TIF format. This will create a TIF file with the 

geographic coordinates embedded in the header of the file, also known as a geotif.  

Edit a data layer and create a new feature 

You’ll create a new layer of buildings in the vicinity of 

the project to which you will add the proposed building 

footprint. You’ll select the 60 or so nearby buildings 

footprints features and export to a new shapefile. 

1. Turn off all of the layers except the buildings. 

2. Type 5000 in the scale box. 

3. Click the Select Features tool and drag a box 

around the buildings near your parcel. In the 

lower left corner of the ArcMap window it will tell you how many buildings are selected; if the 

number is greater than 80, try dragging a smaller box to select fewer features. 

4. Export these to a new shapefile called PD_buildings.shp (project design buildings). Save 

PD_buildings.shp in your usertemp folder. Add the new layer to the map.    

Now you’ll trace the building footprint from the image into the PD_buildings.shp layer. 

1. Clear the selected features, and turn off the old, larger Buildings layer. 

2. Click the Editor Toolbar button ( ) to add the Editor toolbar to the map, or add it like any of 

the other toolbars (by right clicking in the top grey area). 
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3. Click Editor on the Editor toolbar and click Start Editing. 

4. Choose to edit the features in the shapefiles in your usertemp folder (if there is a coordinate 

system warning, just click OK). 

5. Zoom in close to the image you georeferenced. Turn the Bldg_FP.bmp image layer on.   

6. Select PD_buildings on the right side to sketch a new feature. 

7. Click on one corner of the building footprint (it is a light blue 

square on the parcel surrounded by the control points), and 

then in sequence, following the outline of the blue rectangle 

from the image you georeferenced, click to add the 

vertices that define the shape of the building. 

8. When you get back to the first vertex you added, right 

click and click Finish Sketch, or double click (if you were 

not adding a new building to the existing PD_buildings 

layer, then you would create a new, empty data layer in 

ArcCatalog first, then add that into ArcMap for editing).   

9. Click the Attributes ( ) button on the Editor toolbar. 

10. You can edit the attributes of the new parcel footprint 

feature. In the FCODE field type 888 and in the HIGHELEV 

field type 44. In the ROOFELEV field type 33. 

11. Click Editor > Save Edits. Click Editor > Stop Editing. 

Generating contour lines from terrain data 

Now you’ll get some terrain data and derive contour lines from it. 

4. Add the projelev raster dataset (it is stored as a Grid data type).   

This is a raster, like the image you georeferenced, but instead of having color codes to represent a 

picture, each cell/pixel in this raster has an elevation value, to represent the height of the terrain in that 

cell. Because it is GIS data and already has its coordinate system information defined, it falls right into 

place and you don’t have to georeference it. This data is derived from a one-meter resolution digital 

elevation model (DEM) for Boston based on LIDAR data. The original data is in the MIT Geodata 

Repository. You can find additional sources for elevation data, anywhere in the world, at the MIT GIS 

Services website. 

High resolution digital elevation models are not easy to obtain 

outside of US metro areas. In much of the world you’ll have to 

get by with the free 90m resolution data (SRTM) or 30m 

resolution data (ASTER), collect your own elevation data, or pay 

a lot of money to get someone to create it. Elevation rasters can 

make good background images in maps, but for this project 

you’ll use a geoprocessing tool to extract contour line features 

from the elevation raster. 
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5. Click the Toolbox button ( ). 

There are a lot of tools in ArcToolbox that can be used to process geographic data of various sorts in 

different ways. We’ll use a tool from the 3D Analyst extension to derive the contour lines.  First you’ll 

need to enable the extension on your machine. 

6. Click the Customize > Extensions. 

7. Check the box next to 3D Analyst. This will enable the 3D Analyst tools in ArcToolbox. Click 

Close. 

8. At the right of your screen is a Search tab. Click the Search tab, select Tools, and type contour in 

the search box, then press Enter. 

9. Click the Contour tool from the 3D Analyst tools toolbox, to run 

the tool. 

10. Since you ran this tool from within ArcMap, and you have 

layers on your map, the Input raster box will show a list of 

layers when you click in it. Choose the ProjElev layer as the 

input. 

11. For the Output polyline features, click the browse button (a 

folder with an arrow) and navigate to your usertemp folder.  

Name the output contours.shp, then click Save. 

12. Set contour interval to 1 and set the base contour value to 0.   

Since the data is in meters, a value of 1 will output a contour line at 

every meter of elevation change. Because the elevation data and the XY coordinates for this raster are in 

meters, the Z factor is 1 (if you have data where the XY coordinates of the raster are in meters but the 

elevation data is in feet you would use a z-factor of 0.3048 to convert your z-units from feet to meters (1 

foot = 0.3048 meter). 

13. Click OK to run the tool. Close window when it has 

finished. 

14. Turn on and order your layers as such: PD_Buildings, 

contours, Parcels. Turn off projelev 

15. Change the line color to a dark gray.  

16. Double click on the contours layer, and switch to the Labels tab. Turn on labeling for the 

Contours layer, and use the Contour attribute as the label field. 

If you change the symbology to graduated colors, it becomes more obvious that the building you just 

drew is in one of the lower elevation areas. Symbology colors cannot be saved when exporting to 

AutoCAD, but the symbology will remain the same as displayed in ArcMap if the data is exported to AI or 

an image format. Other tools available as part of the surface analysis portions of the 3D analyst and 

spatial analyst extensions include generating slope, aspect, hillshade, and viewsheds.  

Working in 3D with ArcGlobe 
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There are two other programs for working with 3D data that get installed with ArcGIS when you have 

the 3D Analyst extension: ArcScene and ArcGlobe. The MIT site license includes this extension. ArcScene 

has no built-in data and is best used to visualize smaller sets of local data. ArcGlobe is newer, has some 

built-in base map data, and lets you visualize 3D data from local to global scales. It looks similar to 

Google Earth when you open it. 

1. Start ArcGlobe (Start menu > ArcGIS > 

ArcGlobe). 

2. Click the Add Data button, and navigate 

to your usertemp folder. Add 

PD_buildings to ArcGlobe.  

3. For each feature layer you add to 

ArcGlobe, you will be prompted to choose 

what scale it will be displayed at, and how 

the features should be displayed. Use the 

slider to choose a local level, “House 

property”, near the right of the green 

segment of the Typical Scale slider. Click Next > Finish. 

4. Add Data again, and add the local elevation data, ProjElev, to ArcGlobe and choose for it to be 

displayed as elevation source data (the second of the two options). ArcGlobe has some terrain 

data, but this local data is higher resolution. Click Finish. 

5. Right-click the PD_buildings layer in ArcGlobe table of contents and click Zoom to Layer. Make 

sure it is displayed above the Imagery layer in the table of contents, within the Draped Layers 

category. 

Set the buildings to display in 3D 

1. Double click PD_buildings > Globe 

Extrusion tab, and check the box to 

Extrude features in layer. 

2. Click the calculator button beside the 

Extrusion value or expression box. In the 

Expression Builder double click 

ROOFELEV to set the extrude value equal 

to the roofline attribute. Click OK > OK. 

Now you can see an approximation of 

the building masses in 3D.   

3. Double click PD_buildings > Symbology > 

Categories > Unique values. 

4. Set the value field to be FCODE. Click Add Values. Add the value 888 (the ID number you 

assigned the building footprint you digitized). Click Add. 
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5. Change the color of your building to something that contrasts with the “All other features” 

color. 

Navigating in ArcGlobe 

1. Click the Navigate tool (on the left-most end 

of the ArcGlobe navigation toolbar, it looks 

like a little globe with arrows around it). 

2. Click low on the display and slowly drag up 

to change the display angle. 

3. Click on the display and drag left or right to 

rotate around the center (your building). 

4. Right click and push the mouse away from 

you to zoom out. Right click and pull the 

mouse toward you to zoom in. 

5. Save the Globe document in your usertemp folder. 

Challenge exercise 

1. Create bookmarks of three views of the building and 

surroundings. 

2. Create an animation that flies between the three. 

3. Export the animation to an AVI file. 

For more opportunities to learn GIS: 

Workshops previously offered by MIT GIS Services: http://libraries.mit.edu/gis/teach/previous-

workshops.html .This has many resources, including presentation and exercise material, and in some 

cases recordings of the workshop.  

ESRI Virtual Campus classes (MIT only) : http://libraries.mit.edu/gis/teach/esrivc.html 

ESRI online courses offered free to anyone : 

http://training.esri.com/gateway/index.cfm?fa=search.results&cannedsearch=2 

ArcGIS Desktop Tutorials :  http://webhelp.esri.com/arcgisdesktop/9.3/index.cfm?TopicName=Tutorials 

ESRI web-based help overview : http://webhelp.esri.com/ 

The Open Source Geospatial Foundation (OSGEO) listing of educational materials 

http://wiki.osgeo.org/wiki/Educational_Content_Inventory  

Boston GIS Teaching Alliance online teaching resources: 

https://wikis.uit.tufts.edu/confluence/display/GISTA/Online+Teaching+Resources 
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